Nice PayPal Button Lite

Get a very versatile eCommerce solution for WordPress

  • Compatible: WordPress 4.6
  • Version: 1.3.5
  • File size: 9.2 KB
  • Downloads: 1,503

PayPal has upgraded their IPN service to HTTP 1.1. This change will require all site's that use PayPal's IPN services to comply with the new change by February 1, 2013. Nice Memberships extension for Joomla uses PayPal's IPN service and will be effected by PayPal's change.

According to PayPal
"Starting February 1, 2013, we will require all incoming requests to have a “Host” header which complies with HTTP 1.1 specifications. This header was not required under HTTP 1.0. IPN and PDT scripts using HTTP 1.0 may start failing with “HTTP/1.1 400 Bad Request” errors after February 1, 2013, which will result in IPN messages not being validated successfully, or PDT scripts not being able to retrieve transaction information."

If you are using the latest Nice Memberships version 1.11 (or greater) for Joomla 1.6-2.5, your service will not be effected. The 1.11 version contains the new HTTP 1.1 requirement to communicate with PayPal's IPN system. All other versions of Nice Memberships will need to be upgraded to avoid interruption in PayPal's IPN service.

Nice Memberships